summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loky/loky-3.4.1.ebuild')
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
index 456f7062da8e..350d7adf44ee 100644
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing
@@ -40,9 +40,16 @@ python_test() {
EPYTEST_DESELECT=(
# docker, seriously?
tests/test_loky_module.py::test_cpu_count_cfs_limit
+ tests/test_loky_module.py::test_cpu_count_cgroup_limit
# hangs, and even pytest-timeout does not help
tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ # Python 3.12 raises an additional warning due to the use of fork()
+ # in a multithreaded process, the additional warning breaks this test
+ # since the expected warning is no longer the first.
+ # This is harmless, skip test for now
+ tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
+ tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1