summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loky')
-rw-r--r--dev-python/loky/Manifest2
-rw-r--r--dev-python/loky/loky-2.9.0.ebuild38
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild59
-rw-r--r--dev-python/loky/metadata.xml8
4 files changed, 67 insertions, 40 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index 45b7ee061405..6f1944666588 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1 +1 @@
-DIST loky-2.9.0.tar.gz 115019 BLAKE2B 2aa2042e32821b67db8b8de12d4b380d22af93d308bb35878271a4859325d6740a3bdab70b464a2c0d0af143903c8af3da81b4b804605cdae88779fefd7971a6 SHA512 d49354b834251f6f05a689ac44464aafa5a7a5b4a8ef84a308ec3bda138e810fc3dc31aa628307984dc69386a210f442d4c202b9499ae3e3864837b47a5b0cd9
+DIST loky-3.4.1.gh.tar.gz 143933 BLAKE2B b55dc9fe431769de6bc7f8d9854c40a361566d9c0325c7037255c5ce2b9875ff071743892ec5db53be7744955558195eb40fc5467917eeba3d533c68f285a1ec SHA512 435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06
diff --git a/dev-python/loky/loky-2.9.0.ebuild b/dev-python/loky/loky-2.9.0.ebuild
deleted file mode 100644
index 0cf126c023e3..000000000000
--- a/dev-python/loky/loky-2.9.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-inherit distutils-r1
-
-DESCRIPTION="Robust and reusable Executor for joblib"
-HOMEPAGE="https://github.com/joblib/loky"
-SRC_URI="
- https://github.com/joblib/loky/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local args=(
- # docker, seriously?
- --deselect 'tests/test_loky_module.py::test_cpu_count_cfs_limit'
- # one test that uses a lot of memory, also broken on 32-bit
- # platforms
- --skip-high-memory
- )
-
- pytest -vv "${args[@]}" || die "Tests failed on ${EPYTHON}"
-}
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
new file mode 100644
index 000000000000..97ce588e59b8
--- /dev/null
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="
+ https://github.com/joblib/loky/
+ https://pypi.org/project/loky/
+"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ tests/test_loky_module.py::test_cpu_count_cgroup_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
+ # Python 3.12 raises an additional warning due to the use of fork()
+ # in a multithreaded process, the additional warning breaks this test
+ # since the expected warning is no longer the first.
+ # This is harmless, skip test for now
+ tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
+ tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
diff --git a/dev-python/loky/metadata.xml b/dev-python/loky/metadata.xml
index 266e3f19ca59..8bcdc2070db4 100644
--- a/dev-python/loky/metadata.xml
+++ b/dev-python/loky/metadata.xml
@@ -1,7 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>python@gentoo.org</email>
+ <name>Python</name>
</maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">loky</remote-id>
+ <remote-id type="github">joblib/loky</remote-id>
+ </upstream>
</pkgmetadata>