summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/looseversion/looseversion-1.3.0.ebuild')
-rw-r--r--dev-python/looseversion/looseversion-1.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/looseversion/looseversion-1.3.0.ebuild b/dev-python/looseversion/looseversion-1.3.0.ebuild
new file mode 100644
index 000000000000..6654b11d9f0b
--- /dev/null
+++ b/dev-python/looseversion/looseversion-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="A backwards/forwards-compatible fork of distutils.version.LooseVersion"
+HOMEPAGE="
+ https://pypi.org/project/looseversion/
+ https://github.com/effigies/looseversion
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}