summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lz4/lz4-4.0.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-4.0.2.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/lz4/lz4-4.0.2.ebuild b/dev-python/lz4/lz4-4.0.2.ebuild
deleted file mode 100644
index 10c11eec6203..000000000000
--- a/dev-python/lz4/lz4-4.0.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="LZ4 Bindings for Python"
-HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 arm arm64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- app-arch/lz4:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # lz4.stream is not officially supported and not installed by default
- # (we do not support installing it at the moment)
- tests/stream
-)