summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest2
-rw-r--r--dev-python/lz4/files/lz4-3.1.3-310-readall.patch32
-rw-r--r--dev-python/lz4/lz4-3.1.3.ebuild32
-rw-r--r--dev-python/lz4/lz4-4.3.3.ebuild49
4 files changed, 50 insertions, 65 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 94346fa3a8a5..7ffa09f55d9e 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1 @@
-DIST lz4-3.1.3.tar.gz 159016 BLAKE2B 2ab86799cbd37b96550ebb5d0e1a3c301cbcee2a42c6da189f5ae0fee4eb9c5614860dd044363e2c9312e3ab275eb527a116210604a72bd74354f49589d6567b SHA512 170b5330a8ec0eb4d69f3692c54eaa384fd4de78a7e7db95721d2f1e521ae9558f814e63bbb31db2775a81f7cd7eaea1420ad2c96406cff95d25bc5d30811aba
+DIST lz4-4.3.3.tar.gz 171509 BLAKE2B 7db336fd488ca1ba6bb80ba6a6e66bf1499004bb1ba46a3451c90721d7bb76f49ac5fc5bb5f884e350a29b565a7db14fccb907da925f7b5d14474e030e967e77 SHA512 9bdacf6766cca5d1c59f0a0f795910da104ce51d4c43057c4c07fed98765881a702604d60d22a10dea937c4d683e3fcf07c26a6c7a7b5a15b45759fcedb55900
diff --git a/dev-python/lz4/files/lz4-3.1.3-310-readall.patch b/dev-python/lz4/files/lz4-3.1.3-310-readall.patch
deleted file mode 100644
index 63b306b4e4f3..000000000000
--- a/dev-python/lz4/files/lz4-3.1.3-310-readall.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/lz4/frame/__init__.py b/lz4/frame/__init__.py
-index 5fa03ce..b77c425 100644
---- a/lz4/frame/__init__.py
-+++ b/lz4/frame/__init__.py
-@@ -617,6 +617,17 @@ class LZ4FrameFile(_compression.BaseStream):
- # returns at least one byte (except at EOF)
- return self._buffer.peek(size)
-
-+ def readall(self):
-+ chunks = bytearray()
-+
-+ while True:
-+ data = self.read(io.DEFAULT_BUFFER_SIZE)
-+ chunks += data
-+ if not data:
-+ break
-+
-+ return bytes(chunks)
-+
- def read(self, size=-1):
- """Read up to ``size`` uncompressed bytes from the file.
-
-@@ -632,6 +643,9 @@ class LZ4FrameFile(_compression.BaseStream):
-
- """
- self._check_can_read()
-+
-+ if size < 0 and sys.version_info >= (3, 10):
-+ return self.readall()
- return self._buffer.read(size)
-
- def read1(self, size=-1):
diff --git a/dev-python/lz4/lz4-3.1.3.ebuild b/dev-python/lz4/lz4-3.1.3.ebuild
deleted file mode 100644
index b86d4cd56978..000000000000
--- a/dev-python/lz4/lz4-3.1.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="LZ4 Bindings for Python"
-HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="app-arch/lz4:="
-DEPEND=${RDEPEND}
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-310-readall.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/lz4/lz4-4.3.3.ebuild b/dev-python/lz4/lz4-4.3.3.ebuild
new file mode 100644
index 000000000000..3363be935ab4
--- /dev/null
+++ b/dev-python/lz4/lz4-4.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="
+ https://github.com/python-lz4/python-lz4/
+ https://pypi.org/project/lz4/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha amd64 arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# note: test suite fails with xdist
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+ )
+
+ rm -rf lz4 || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}