summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest3
-rw-r--r--dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch19
-rw-r--r--dev-python/lz4/lz4-3.0.2.ebuild32
-rw-r--r--dev-python/lz4/lz4-3.1.1.ebuild33
-rw-r--r--dev-python/lz4/lz4-4.3.3.ebuild49
-rw-r--r--dev-python/lz4/metadata.xml24
6 files changed, 62 insertions, 98 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 74fd56f30dfc..7ffa09f55d9e 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1,2 +1 @@
-DIST lz4-3.0.2.tar.gz 152443 BLAKE2B 3bf452b5b5ee65caed13b21fd7c39f32ccdea18e6d900facf74e3271868299a2da258b2b0058efaea12a3b42006f0ad0d17004692c95be951c173fee1a1162be SHA512 c31116ee3cd70241b19bff6c59d1852d4c26ad5f0c9a56cd2ecec58e8c2751773162c7ac6a2d887e8cf537bc869ed8866929164f976849efa3ea041eacc4535a
-DIST lz4-3.1.1.tar.gz 154325 BLAKE2B 2d40728087aea735aeac4d39c415edf94f9aca83c77e4a36fe53f6f32f6c1595c0b1ad97c11f6e58cacafb95e0e12d29336d9f072d4f0d47f2d522f552a368bf SHA512 b6ddcabcb323b88eeff1fa9cb91d379d6435ab51b2b51e080138892fbce57d92c8175e2ae1ef72e8a2f95429aaa4be66a5e8cd9d4dbc5bcd6b44ec26b7df96db
+DIST lz4-4.3.3.tar.gz 171509 BLAKE2B 7db336fd488ca1ba6bb80ba6a6e66bf1499004bb1ba46a3451c90721d7bb76f49ac5fc5bb5f884e350a29b565a7db14fccb907da925f7b5d14474e030e967e77 SHA512 9bdacf6766cca5d1c59f0a0f795910da104ce51d4c43057c4c07fed98765881a702604d60d22a10dea937c4d683e3fcf07c26a6c7a7b5a15b45759fcedb55900
diff --git a/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch b/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch
deleted file mode 100644
index 40e6be63ff01..000000000000
--- a/dev-python/lz4/files/lz4-3.0.2-test-fail-skip.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/tests/stream/test_stream_1.py 2020-04-29 13:00:05.213776356 -0700
-+++ b/tests/stream/test_stream_1.py 2020-04-29 13:16:33.958779776 -0700
-@@ -172,6 +172,8 @@
-
-
- def test_invalid_config_d_4(store_comp_size):
-+
-+ pytest.skip('Known test failure, bug: https://github.com/python-lz4/python-lz4/issues/199')
- d_kwargs = {}
- d_kwargs['strategy'] = "double_buffer"
- d_kwargs['buffer_size'] = 1 << (8 * store_comp_size['store_comp_size'])
-@@ -231,6 +233,8 @@
-
-
- def test_invalid_config_d_5():
-+
-+ pytest.skip('Known test failure, bug: https://github.com/python-lz4/python-lz4/issues/199')
- d_kwargs = {}
- d_kwargs['strategy'] = "double_buffer"
diff --git a/dev-python/lz4/lz4-3.0.2.ebuild b/dev-python/lz4/lz4-3.0.2.ebuild
deleted file mode 100644
index 81d3c0303da7..000000000000
--- a/dev-python/lz4/lz4-3.0.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="LZ4 Bindings for Python"
-HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="app-arch/lz4"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# known test failure: https://github.com/python-lz4/python-lz4/issues/199
-PATCHES=( "${FILESDIR}/lz4-3.0.2-test-fail-skip.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/lz4/lz4-3.1.1.ebuild b/dev-python/lz4/lz4-3.1.1.ebuild
deleted file mode 100644
index f2e006ee00d8..000000000000
--- a/dev-python/lz4/lz4-3.1.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="LZ4 Bindings for Python"
-HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="app-arch/lz4"
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/pkgconfig[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# known test failure: https://github.com/python-lz4/python-lz4/issues/199
-PATCHES=(
- "${FILESDIR}/lz4-3.0.2-test-fail-skip.patch"
-)
-
-distutils_enable_tests pytest
diff --git a/dev-python/lz4/lz4-4.3.3.ebuild b/dev-python/lz4/lz4-4.3.3.ebuild
new file mode 100644
index 000000000000..e2db3e16a6a4
--- /dev/null
+++ b/dev-python/lz4/lz4-4.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="
+ https://github.com/python-lz4/python-lz4/
+ https://pypi.org/project/lz4/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# note: test suite fails with xdist
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+ )
+
+ rm -rf lz4 || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/dev-python/lz4/metadata.xml b/dev-python/lz4/metadata.xml
index 503d76895130..d5161622db14 100644
--- a/dev-python/lz4/metadata.xml
+++ b/dev-python/lz4/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">lz4</remote-id>
- <remote-id type="github">steeve/python-lz4</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">lz4</remote-id>
+ <remote-id type="github">python-lz4/python-lz4</remote-id>
+ </upstream>
</pkgmetadata>