summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild')
-rw-r--r--dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild b/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild
new file mode 100644
index 000000000000..c80e3a6b924f
--- /dev/null
+++ b/dev-python/mapbox_earcut/mapbox_earcut-1.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="mapbox_earcut_python-${PV}"
+DESCRIPTION="Python bindings to the mapbox earcut C++ library"
+HOMEPAGE="https://github.com/skogler/mapbox_earcut_python"
+SRC_URI="
+ https://github.com/skogler/mapbox_earcut_python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md README.md )