summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/matplotlib-inline')
-rw-r--r--dev-python/matplotlib-inline/Manifest3
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.2.ebuild21
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.3.ebuild21
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild35
-rw-r--r--dev-python/matplotlib-inline/metadata.xml1
5 files changed, 37 insertions, 44 deletions
diff --git a/dev-python/matplotlib-inline/Manifest b/dev-python/matplotlib-inline/Manifest
index 22f0a9bf8048..f2bb96d1af9a 100644
--- a/dev-python/matplotlib-inline/Manifest
+++ b/dev-python/matplotlib-inline/Manifest
@@ -1,2 +1 @@
-DIST matplotlib-inline-0.1.2.gh.tar.gz 7340 BLAKE2B 026c08d8a96d4402a1b70e50f1adce2b620c17b00d9e4dc365540c41b2d8f189a73cf6c65c8946ae45e7e5325321d28918692c2c6b5f81668fa56fedb40fd425 SHA512 e6ac7efe10979afb773b75c4d2ee321c52b1e9788a80703d063b0936b4989946aa35206ff7e8ad4ffaf6c1116d893de9516fc033f53685ad3a55d8f1a9a8fd48
-DIST matplotlib-inline-0.1.3.gh.tar.gz 7337 BLAKE2B 995b6e5ce9068760e701e3b429d2187bdc7e7c5b989d54a9fb1f8b5f385f91c6a3621a54d5a1e62c9000737f5f42d9ceae5be7f36b664b7e06ff9c712e6d76ac SHA512 684821204faa3cb35c46663b8c8cb8f0ba5d4f761d15bc708de69c98753685c89da1d330087bcfa970792de592188768dc068accc471d55360f551e44cf4a79a
+DIST matplotlib-inline-0.1.7.gh.tar.gz 8112 BLAKE2B 1c1dc0f0d5a86dc5e8fae013f569f16c90466765643a7c2ef7359f906bec18bbe4bd27502cef78a3edc4f3a617416389648cbb9abab75ba804fbce85de838cec SHA512 b424b42c221227fe8807a4c56207aa3f0830cd857b816e278d4d22a57091598b9a4f3de5f046d9e8722a6cae13a8f187ffc24927071592ff514b1add3962d03f
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.2.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.2.ebuild
deleted file mode 100644
index 601008516c97..000000000000
--- a/dev-python/matplotlib-inline/matplotlib-inline-0.1.2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Inline Matplotlib backend for Jupyter"
-HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
-SRC_URI="
- https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]"
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.3.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.3.ebuild
deleted file mode 100644
index 50c6f3da0068..000000000000
--- a/dev-python/matplotlib-inline/matplotlib-inline-0.1.3.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Inline Matplotlib backend for Jupyter"
-HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
-SRC_URI="
- https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]"
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild
new file mode 100644
index 000000000000..8f1788e982c8
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/matplotlib-inline/
+ https://pypi.org/project/matplotlib-inline/
+"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+
+# Although in theory we could depend on matplotlib, upstream does not.
+# This is because the sole purpose of the package is to be loaded by
+# ipython (also not a dependency!) as a response to interactive use of
+# the "%matplotlib" magic.
+#
+# In order to be seamless and straightforward, this backend is always
+# installed and just requires users using matplotlib, to install
+# matplotlib before importing and using it.
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/matplotlib-inline/metadata.xml b/dev-python/matplotlib-inline/metadata.xml
index aad2292b4508..db1e0b9d696a 100644
--- a/dev-python/matplotlib-inline/metadata.xml
+++ b/dev-python/matplotlib-inline/metadata.xml
@@ -4,6 +4,7 @@
<maintainer type="project">
<email>python@gentoo.org</email>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">ipython/matplotlib-inline</remote-id>
<remote-id type="pypi">matplotlib-inline</remote-id>