summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mecab-python/mecab-python-0.996-r1.ebuild')
-rw-r--r--dev-python/mecab-python/mecab-python-0.996-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/mecab-python/mecab-python-0.996-r1.ebuild b/dev-python/mecab-python/mecab-python-0.996-r1.ebuild
new file mode 100644
index 000000000000..1a7d1ba9e4b1
--- /dev/null
+++ b/dev-python/mecab-python/mecab-python-0.996-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for MeCab"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN%-*}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86"
+
+DEPEND="~app-text/mecab-${PV}"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-python3.patch )
+DOCS=( AUTHORS README test.py )
+HTML_DOCS=( bindings.html )
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests failed with ${EPYTHON}"
+}