summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mecab-python/mecab-python-0.996.ebuild')
-rw-r--r--dev-python/mecab-python/mecab-python-0.996.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/mecab-python/mecab-python-0.996.ebuild b/dev-python/mecab-python/mecab-python-0.996.ebuild
index e9ff194d7f77..8f85ac04d759 100644
--- a/dev-python/mecab-python/mecab-python-0.996.ebuild
+++ b/dev-python/mecab-python/mecab-python-0.996.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python binding for MeCab"
@@ -13,7 +13,6 @@ SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.go
LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc64 x86"
-IUSE=""
DEPEND="~app-text/mecab-${PV}"
RDEPEND="${DEPEND}"
@@ -21,3 +20,7 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-python3.patch )
DOCS=( AUTHORS README test.py )
HTML_DOCS=( bindings.html )
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests failed with ${EPYTHON}"
+}