summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mistletoe/mistletoe-1.2.0.ebuild')
-rw-r--r--dev-python/mistletoe/mistletoe-1.2.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/mistletoe/mistletoe-1.2.0.ebuild b/dev-python/mistletoe/mistletoe-1.2.0.ebuild
deleted file mode 100644
index 7aef7cc9a0be..000000000000
--- a/dev-python/mistletoe/mistletoe-1.2.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A fast, extensible Markdown parser in pure Python"
-HOMEPAGE="
- https://github.com/miyuchina/mistletoe/
- https://pypi.org/project/mistletoe/
-"
-# pypi has incomplete test suite
-SRC_URI="
- https://github.com/miyuchina/mistletoe/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# NB: pygments is technically optional but we like syntax highlighting
-RDEPEND="
- dev-python/pygments[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest