summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest4
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild (renamed from dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild)32
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild (renamed from dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild)32
3 files changed, 38 insertions, 30 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 9a3ffcb3f1c9..2017b4996a4f 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1,2 +1,2 @@
-DIST mkdocs-git-authors-plugin-0.6.2.tar.gz 27623 BLAKE2B 7b0dd3b865b067b63e467fa75018a92cea8cfeabdeb66791664ea143ebecbb072110698f1366f917f390dd29c33794c7d2cc03e03bb84f8913b572d667e77b9d SHA512 75e4a4e6f3ca443257b5f61f5f0d9784cb4bb28a5a03412cde5c226da697117a29c2f4a3d1cac2aa362421f244fd56ea8580a923414a8e096bedc4502afcb5b0
-DIST mkdocs-git-authors-plugin-0.6.3.tar.gz 27644 BLAKE2B a8778baeb504db5d0571aa20603e8d60e04d8c315c096b5b3f89bb6a3b433a11b04a510d7f80ae86a9bb54259c6a2b0f2e1cb5cdade4220d4dfa1f06612e4aea SHA512 ab1f6984da002b72af2a53131222a3ff7b6b50a7a57f5d1986bca9e7d34365eaa5bfdf7d920e4dbc555e332587607480eef4134d847faf866a3b4750db3747eb
+DIST mkdocs-git-authors-plugin-0.8.0.gh.tar.gz 30080 BLAKE2B 08c0eee392ef94caf30f176f5c8923b4e3c5d951a36348bbeec4396052ee492715b99aa4f8824348728296e5276747083340943bd21f7850abd0ccfb3a2bf12c SHA512 4620c8cccf69eb8ec3010ac7483a3df1ab43bcf8e0837399f46383d9947fdddc0c70d7d8405c820f1cb4b773724ca7006f2cc3bdd5559c107a2db8e3ceb8b38e
+DIST mkdocs-git-authors-plugin-0.9.0.gh.tar.gz 30785 BLAKE2B babf9c6b200ee3ea6839e4b35c78e83c727477b9dbaee027fda49500d7b8bb57ffea2d960a2ca979ee8cb2e499a004dc49ca417c4a96054dad27408e4bbb0607 SHA512 66527124217eecef80025517b1fabe9b81c3b65808f0c32610a8333ace2bec1dbb316ad35aec819c03482e9a09961f8cf84f8b1c2f5bdfbd5e270c07019f06e6
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild
index 5e3f4cc0b40d..5389f25f3556 100644
--- a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.2.ebuild
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.8.0.ebuild
@@ -1,12 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="dev-python/mkdocs-material"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
inherit distutils-r1 docs
@@ -15,11 +23,14 @@ HOMEPAGE="
https://github.com/timvink/mkdocs-git-authors-plugin/
https://pypi.org/project/mkdocs-git-authors-plugin/
"
-SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
RDEPEND="
dev-python/GitPython[${PYTHON_USEDEP}]
@@ -32,20 +43,13 @@ BDEPEND="
dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
dev-vcs/git
)
- doc? ( dev-vcs/git )
"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
python_prepare_all() {
# mkdocs-git-authors tests need git repo
- if use test || use doc; then
- git init -q || die
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git add . || die
- git commit -qm 'init' || die
- fi
+ use test && initialize_git_repo
distutils-r1_python_prepare_all
}
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild
index 5e3f4cc0b40d..919c58515e2b 100644
--- a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.3.ebuild
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.9.0.ebuild
@@ -1,12 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="dev-python/mkdocs-material"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
inherit distutils-r1 docs
@@ -15,11 +23,14 @@ HOMEPAGE="
https://github.com/timvink/mkdocs-git-authors-plugin/
https://pypi.org/project/mkdocs-git-authors-plugin/
"
-SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
RDEPEND="
dev-python/GitPython[${PYTHON_USEDEP}]
@@ -32,20 +43,13 @@ BDEPEND="
dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
dev-vcs/git
)
- doc? ( dev-vcs/git )
"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
python_prepare_all() {
# mkdocs-git-authors tests need git repo
- if use test || use doc; then
- git init -q || die
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
- git add . || die
- git commit -qm 'init' || die
- fi
+ use test && initialize_git_repo
distutils-r1_python_prepare_all
}