summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocs')
-rw-r--r--dev-python/mkdocs/Manifest3
-rw-r--r--dev-python/mkdocs/mkdocs-1.2.2.ebuild73
-rw-r--r--dev-python/mkdocs/mkdocs-1.5.3-r1.ebuild85
-rw-r--r--dev-python/mkdocs/mkdocs-1.6.0.ebuild86
4 files changed, 173 insertions, 74 deletions
diff --git a/dev-python/mkdocs/Manifest b/dev-python/mkdocs/Manifest
index 387f97be7b34..8e5fd03923d0 100644
--- a/dev-python/mkdocs/Manifest
+++ b/dev-python/mkdocs/Manifest
@@ -1 +1,2 @@
-DIST mkdocs-1.2.2.tar.gz 6919165 BLAKE2B eba8d585c3653640bd3babbba3a1fab6aa9dc3ee365536ee7b0956e38250611bab3180c6a7f08eefb1e1a3637d07a0f366179570a9bb69df4f02a605610a770f SHA512 6cb111fcb3167a39e1d282d24b5e67d806c3e7506f55ef11a227b37ceeaea950142db2bc1db3709caaa2813c62ef8c4ef74aeb26e62f4f10aeee528e0532eccd
+DIST mkdocs-1.5.3.gh.tar.gz 4057780 BLAKE2B d1e7ac739ea3a78f2a2d294a28c721f95cb8be6c114a5131893e346254ed1937218cc0d247e75092876d7f42dc04c8060fdc8d7535326f26a8f68ec11bc7045b SHA512 3f7d0af4b071ac6998e82cefb18df27f1cc98d91c7902d2943acdaa08c56f90e36c1c5d1df1c1f61a1c50d8fecc2fb0014497f2436be89d52b17959808c31abc
+DIST mkdocs-1.6.0.gh.tar.gz 4494411 BLAKE2B 2a0d55c54509827fcff39c04812be6cff6b1ccbf823cc05a48fa154745a49aed08d811147fc5f64db138ede952dc89241b156f8e0e01e42a468f73309eece0fb SHA512 330dfb7cd390b320ca9c2bfd2dc248d877b95713ec3c1d2c9d5b28be52a42276c58412bc77527a492e4b1b31608e3093dbad2a983bfe6396577ec7464e274609
diff --git a/dev-python/mkdocs/mkdocs-1.2.2.ebuild b/dev-python/mkdocs/mkdocs-1.2.2.ebuild
deleted file mode 100644
index 43061c17c2da..000000000000
--- a/dev-python/mkdocs/mkdocs-1.2.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Project documentation with Markdown"
-HOMEPAGE="https://www.mkdocs.org https://github.com/mkdocs/mkdocs"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-IUSE="doc"
-
-BDEPEND="
- doc? (
- $(python_gen_any_dep '
- dev-python/mdx_gh_links[${PYTHON_USEDEP}]
- dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RDEPEND="
- >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/click-3.3[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
- >=dev-python/markdown-3.2.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
- >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
- >=dev-python/importlib_metadata-3.10[${PYTHON_USEDEP}]
- >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
- >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests --install nose
-
-python_prepare_all() {
- # Tests fails if additional themes are installed
- sed -i -e 's:test_get_themes:_&:' \
- mkdocs/tests/utils/utils_tests.py || die
-
- # Skip this network test, "does not appear to be an IPv4 or IPv6 address"
- sed -i -e 's/test_IP_normalization/_&/' \
- mkdocs/tests/config/config_options_tests.py || die
-
- # livereload has been dropped in this release, this test is a remnant
- rm mkdocs/tests/livereload_tests.py || die
-
- # fix apparent typo in test (importing wrong thing)
- sed -i -e 's/from localization import/from mkdocs.localization import/g' \
- mkdocs/tests/theme_tests.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- default
- if use doc; then
- # cannot just do mkdocs build, because that fails if
- # the package isn't already installed
- python -m mkdocs build || die "Failed to make docs"
- # Colliding files found by ecompress:
- rm site/sitemap.xml.gz || die
- HTML_DOCS=( "site/." )
- fi
-}
diff --git a/dev-python/mkdocs/mkdocs-1.5.3-r1.ebuild b/dev-python/mkdocs/mkdocs-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..3747c36b27cc
--- /dev/null
+++ b/dev-python/mkdocs/mkdocs-1.5.3-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Project documentation with Markdown"
+HOMEPAGE="
+ https://www.mkdocs.org/
+ https://github.com/mkdocs/mkdocs/
+ https://pypi.org/project/mkdocs/
+"
+SRC_URI="
+ https://github.com/mkdocs/mkdocs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~riscv x86"
+
+# https://bugs.gentoo.org/873349
+# Building documentation requires packaging: callouts and mkdocs-autorefs
+#
+# IUSE="doc"
+#
+# BDEPEND="
+# doc? (
+# $(python_gen_any_dep '
+# dev-python/mdx-gh-links[${PYTHON_USEDEP}]
+# dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
+# ')
+# )
+# "
+RDEPEND="
+ >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3.3[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
+ >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Tests fails if additional themes are installed
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_error
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_warning
+
+ # Does not work in emerge env
+ mkdocs/tests/config/config_options_tests.py::ListOfPathsTest::test_paths_localized_to_config
+
+ # TODO
+ mkdocs/tests/build_tests.py::testing_server
+ mkdocs/tests/livereload_tests.py::testing_server
+)
+
+python_compile_all() {
+ default
+# if use doc; then
+# # cannot just do mkdocs build, because that fails if
+# # the package isn't already installed
+# python -m mkdocs build || die "Failed to make docs"
+# # Colliding files found by ecompress:
+# rm site/sitemap.xml.gz || die
+# HTML_DOCS=( "site/." )
+# fi
+}
+
+python_test() {
+ epytest '-opython_files=*tests.py' mkdocs/tests
+}
diff --git a/dev-python/mkdocs/mkdocs-1.6.0.ebuild b/dev-python/mkdocs/mkdocs-1.6.0.ebuild
new file mode 100644
index 000000000000..47af3bf96ea3
--- /dev/null
+++ b/dev-python/mkdocs/mkdocs-1.6.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Project documentation with Markdown"
+HOMEPAGE="
+ https://www.mkdocs.org/
+ https://github.com/mkdocs/mkdocs/
+ https://pypi.org/project/mkdocs/
+"
+SRC_URI="
+ https://github.com/mkdocs/mkdocs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# https://bugs.gentoo.org/873349
+# Building documentation requires packaging: callouts and mkdocs-autorefs
+#
+# IUSE="doc"
+#
+# BDEPEND="
+# doc? (
+# $(python_gen_any_dep '
+# dev-python/mdx-gh-links[${PYTHON_USEDEP}]
+# dev-python/mkdocs-redirects[${PYTHON_USEDEP}]
+# ')
+# )
+# "
+RDEPEND="
+ >=dev-python/Babel-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3.6[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-2.0[${PYTHON_USEDEP}]
+ >=dev-python/ghp-import-1.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.11.1[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml_env_tag-0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.5[${PYTHON_USEDEP}]
+ >=dev-python/mergedeep-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-get-deps-0.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Tests fails if additional themes are installed
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_error
+ mkdocs/tests/utils/utils_tests.py::UtilsTests::test_get_themes_warning
+
+ # Does not work in emerge env
+ mkdocs/tests/config/config_options_tests.py::ListOfPathsTest::test_paths_localized_to_config
+
+ # TODO
+ mkdocs/tests/build_tests.py::testing_server
+ mkdocs/tests/livereload_tests.py::testing_server
+)
+
+python_compile_all() {
+ default
+# if use doc; then
+# # cannot just do mkdocs build, because that fails if
+# # the package isn't already installed
+# python -m mkdocs build || die "Failed to make docs"
+# # Colliding files found by ecompress:
+# rm site/sitemap.xml.gz || die
+# HTML_DOCS=( "site/." )
+# fi
+}
+
+python_test() {
+ epytest '-opython_files=*tests.py' mkdocs/tests
+}