summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index c514f9ad08dc..31b07ec97045 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-python-1.7.0.gh.tar.gz 136113 BLAKE2B a1ccb8ff817beaa89fb8234c60920a3b60e57d3908e103279728a9b0d6c4b53132da5262001b9a0e89b161e5e96226ddd06e0b224db4c869cb99297a6c646167 SHA512 2e1b855c8ad51b8066e3ff1036cf6d0ee90b766f7f851a6045707889e39ca9217f9a747bff0069614e89154356224a670b4de6f8a678439bbff63d4e3ffb6b70
+DIST mkdocstrings-python-1.7.1.gh.tar.gz 136263 BLAKE2B c3c5661f7afd94c4233bd737ff1129f280825a6acc6c868867443e3eab76f4d22732895de486784f0c3f163ded45e7c9a6954768f13fde3bfc1404e76ea9224b SHA512 dfa05086d12805975e68bebabc47e2bfdeca67c7dc799312e3d719142b7bea995f06ed8c5b4699ffbb58647e0a1f6be23dc17a76ff8c7008587ccc3af72c56f9
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.1.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.1.ebuild
new file mode 100644
index 000000000000..f0b94cc2c39d
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.35[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}