summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest1
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.22.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 327520f07eb7..831119bbbed0 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-0.21.2.gh.tar.gz 69412 BLAKE2B 2e941045c3f9473ec83a60b82ae85ffbb200201295a8d4405648b4b65ef282fa189b01f54107e999946ce90fbea34a798177dd3d0dbd138a5db6e507cbc0ef7d SHA512 0880163679cce78432880904c6a56eae533a2d6a167b109a21c45daf5f76abf433243b54bcbb0507b5b42c3df9d9d93367cb2bde996c2dcdcc3e55320b2be35c
+DIST mkdocstrings-0.22.0.gh.tar.gz 81345 BLAKE2B ee2bcc0084c5d17368bc1a04db2f097f997872b38fd6b3d32f7daaefe78a496bb0a23d6588458a65b827954382e11c6b6d81baa2117af4b3341e9e727c616ca0 SHA512 c6226d50aaf029a139f51bb1f7101446e11a3e1337f7cd1c9324a2e258753cf25911b2da7042a08a64ae4cf51987b0b2a6ab752af408cdb54d436bcc908d66ff
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.22.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.22.0.ebuild
new file mode 100644
index 000000000000..81bd657d2b5b
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.22.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocs-autorefs/
+"
+# Tests require files absent from PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/mkdocstrings/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jinja-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.3[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.2[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # TODO: package markdown-exec
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}