summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/montage-wrapper/montage-wrapper-0.9.9.ebuild')
-rw-r--r--dev-python/montage-wrapper/montage-wrapper-0.9.9.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/montage-wrapper/montage-wrapper-0.9.9.ebuild b/dev-python/montage-wrapper/montage-wrapper-0.9.9.ebuild
new file mode 100644
index 000000000000..409d24f27653
--- /dev/null
+++ b/dev-python/montage-wrapper/montage-wrapper-0.9.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Montage mosaicking toolkit"
+HOMEPAGE="http://www.astropy.org/montage-wrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ sci-astronomy/montage"
+DEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( sci-astronomy/montage )"
+
+python_prepare_all() {
+ # use system astropy-helpers instead of bundled one
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ PYTHONPATH=".." emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}