summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/msgpack/msgpack-0.4.8.ebuild')
-rw-r--r--dev-python/msgpack/msgpack-0.4.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/msgpack/msgpack-0.4.8.ebuild b/dev-python/msgpack/msgpack-0.4.8.ebuild
new file mode 100644
index 000000000000..b05c5f843986
--- /dev/null
+++ b/dev-python/msgpack/msgpack-0.4.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="http://msgpack.org https://github.com/msgpack/msgpack-python/ https://pypi.python.org/pypi/msgpack-python/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test test || die "Tests fail with ${EPYTHON}"
+}