summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/natsort/natsort-8.0.1.ebuild')
-rw-r--r--dev-python/natsort/natsort-8.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/natsort/natsort-8.0.1.ebuild b/dev-python/natsort/natsort-8.0.1.ebuild
new file mode 100644
index 000000000000..e1a2a2c8074f
--- /dev/null
+++ b/dev-python/natsort/natsort-8.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest