summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/natsort')
-rw-r--r--dev-python/natsort/Manifest1
-rw-r--r--dev-python/natsort/natsort-7.1.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/natsort/Manifest b/dev-python/natsort/Manifest
index 2496903f72af..a1bdb8cd5459 100644
--- a/dev-python/natsort/Manifest
+++ b/dev-python/natsort/Manifest
@@ -1 +1,2 @@
DIST natsort-7.1.0.tar.gz 143534 BLAKE2B 3ab6c977aca40330fac0af9e4be36d973e88d931799b3135a81daf0a475988af5cc2f9abb30ade1498aad07d9c986e514c7c8cdbbb63da195a81dded4f6f25da SHA512 41293d70c3dc2214f9dc1c123f31cd7886341ae25c6342ac49f3d53d06ba15ecd8d666f1763fe790848c93668940a81b7e7f1fe896f0b91f180ca557dd922ac3
+DIST natsort-7.1.1.tar.gz 142749 BLAKE2B dffd5b7b18ac49653d4d65ae1335c85d441748903aa983df092778476988cf0ca59c08526ee0da1761fce1afe4849d4c9a9e2f3e0c5400ebca2478781d0986dc SHA512 1903c933c6203ef0cd194ea444d79276b79ec385728a92b6e73d1698abc8e1351e96ed8ea4ae5f9f413ef6daecfd269a4d0de74c45eedff682fe929d8f977f30
diff --git a/dev-python/natsort/natsort-7.1.1.ebuild b/dev-python/natsort/natsort-7.1.1.ebuild
new file mode 100644
index 000000000000..4e20f739fa86
--- /dev/null
+++ b/dev-python/natsort/natsort-7.1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Natural sorting for Python"
+HOMEPAGE="https://pypi.org/project/natsort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest