summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nbval/nbval-0.9.6.ebuild')
-rw-r--r--dev-python/nbval/nbval-0.9.6.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/nbval/nbval-0.9.6.ebuild b/dev-python/nbval/nbval-0.9.6.ebuild
deleted file mode 100644
index dd3f21a47ef9..000000000000
--- a/dev-python/nbval/nbval-0.9.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="A py.test plugin to validate Jupyter notebooks"
-HOMEPAGE="https://github.com/computationalmodelling/nbval"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="test? ( dev-python/sympy[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- --deselect tests/test_ignore.py::test_conf_ignore_stderr
- --deselect tests/test_timeouts.py::test_timeouts
- )
-
- pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
-}