summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nnpy/nnpy-1.2-r1.ebuild')
-rw-r--r--dev-python/nnpy/nnpy-1.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nnpy/nnpy-1.2-r1.ebuild b/dev-python/nnpy/nnpy-1.2-r1.ebuild
new file mode 100644
index 000000000000..f8511201a737
--- /dev/null
+++ b/dev-python/nnpy/nnpy-1.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="cffi-based Python bindings for nanomsg"
+HOMEPAGE="https://github.com/nanomsg/nnpy"
+SRC_URI="https://github.com/nanomsg/nnpy/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+DEPEND="
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-libs/nanomsg:=
+"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" "${S}/test.py" || die
+}