summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nose/nose-1.3.7-r8.ebuild')
-rw-r--r--dev-python/nose/nose-1.3.7-r8.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/nose/nose-1.3.7-r8.ebuild b/dev-python/nose/nose-1.3.7-r8.ebuild
index 993e38c05991..9ff8d8ae5d04 100644
--- a/dev-python/nose/nose-1.3.7-r8.ebuild
+++ b/dev-python/nose/nose-1.3.7-r8.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -20,12 +20,14 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~
IUSE="examples test"
RESTRICT="!test? ( test )"
-DEPEND="${RDEPEND}
+BDEPEND="
test? (
- !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
+ $(python_gen_cond_dep '
+ !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
+ ' python3_{7..9} pypy3)
$(python_gen_cond_dep '
dev-python/twisted[${PYTHON_USEDEP}]
- ' 'python3*')
+ ' python3_{7..9})
)"
PATCHES=(