summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/noseofyeti')
-rw-r--r--dev-python/noseofyeti/Manifest1
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/Manifest b/dev-python/noseofyeti/Manifest
index 30e9c8c79a02..f99957b7e1df 100644
--- a/dev-python/noseofyeti/Manifest
+++ b/dev-python/noseofyeti/Manifest
@@ -1 +1,2 @@
DIST nose-of-yeti-release-2.4.6.gh.tar.gz 44946 BLAKE2B 8a99eb299b389729030d1f5de0f686d4186d1657c41f35aa8712c1a2a8214d808c853e1a435f05a262c676f1f4dcc453fc0541582f45d30f23696a83ec3e9c82 SHA512 276c1ad5d2c67c26ee8d3e3e9184f0881c4084889324e9b45d79897d46d94f64f4fc7267d2578feb76690fd2165633fa217a6bf1588585a5e0cf84dfceaa2a4b
+DIST noseofyeti-2.4.7.tar.gz 35637 BLAKE2B 44524d46ae7a278029ec6a321e4b44085ac9082d0a2fb44726777ff40a575ec100baf5554da29411fef992da0d435cd6c14ff15364ed92d74c98efe32eda56bd SHA512 c6254c54541f9cec2fbe25416013d8f76d0c32c8b403b6ba79b38522460ffbefd29565fc640e8ed54c30efe641755e125a5884a97de4f86a2bd3555bf8f6b294
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.7.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.7.ebuild
new file mode 100644
index 000000000000..10a1b480c93c
--- /dev/null
+++ b/dev-python/noseofyeti/noseofyeti-2.4.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A custom python codec that provides an RSpec style dsl for python"
+HOMEPAGE="
+ https://github.com/delfick/nose-of-yeti/
+ https://pypi.org/project/noseOfYeti/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires alt-pytest-asyncio
+ tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
+)