summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild')
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild
new file mode 100644
index 000000000000..2f680d17f344
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}"