summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ntplib/ntplib-0.3.3.ebuild')
-rw-r--r--dev-python/ntplib/ntplib-0.3.3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/ntplib/ntplib-0.3.3.ebuild b/dev-python/ntplib/ntplib-0.3.3.ebuild
index 388be2874a6b..38cffbd39d3c 100644
--- a/dev-python/ntplib/ntplib-0.3.3.ebuild
+++ b/dev-python/ntplib/ntplib-0.3.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -17,8 +17,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
# tests fail with network-sandbox
+PROPERTIES="test_network"
RESTRICT="test"
python_test() {
- "${EPYTHON}" ./test_ntplib.py || die
+ "${EPYTHON}" ./test_ntplib.py -v || die
}