summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ntplib/ntplib-0.4.0.ebuild')
-rw-r--r--dev-python/ntplib/ntplib-0.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/ntplib/ntplib-0.4.0.ebuild b/dev-python/ntplib/ntplib-0.4.0.ebuild
new file mode 100644
index 000000000000..b5c4c8472001
--- /dev/null
+++ b/dev-python/ntplib/ntplib-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python NTP library"
+HOMEPAGE="https://pypi.org/project/ntplib/"
+SRC_URI="
+ https://github.com/cf-natali/ntplib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests fail with network-sandbox
+PROPERTIES="test_network"
+RESTRICT="test"
+
+python_test() {
+ "${EPYTHON}" ./test_ntplib.py -v || die
+}