summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest2
-rw-r--r--dev-python/nuitka/metadata.xml26
-rw-r--r--dev-python/nuitka/nuitka-0.6.16.3.ebuild48
-rw-r--r--dev-python/nuitka/nuitka-0.6.16.4.ebuild48
4 files changed, 0 insertions, 124 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
deleted file mode 100644
index df731ca1bc3c..000000000000
--- a/dev-python/nuitka/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Nuitka-0.6.16.3.tar.gz 2965278 BLAKE2B fc015f78912688e3d3b0833e7c126833352aeda7ac2599685a007445c43a7099407c4797eba47d5254fb5befde9482c210b920f4c7e38a2d82dbb5331125abee SHA512 a46af040774fd3523b64c1a113f6d0251c8d45108686017dae07429107f5057025bbcfefc7ed2b86da32c69516285d3af55fe234d25d6949562a96b0eb3f5293
-DIST Nuitka-0.6.16.4.tar.gz 2963879 BLAKE2B a6a0029f06aac5ea8fb0fec81ac5b1c5b7bb0ed85bdd0f0308ac74140792360684f42cf79f7ff7e604de3729584b335671ff57f0805aac2154ef1ea88bbbf245 SHA512 e2c73b19e459c31b85adf79270e258ca3c431364ec90b51682a7a324aebfeab1ab7703421e8646e18e0bef62f5f5636bbbda74d0ec0e4666e1571d71d41971b2
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
deleted file mode 100644
index 465fe958dc3b..000000000000
--- a/dev-python/nuitka/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <name>Oz Tiram</name>
- <email>oz.tiram@gmail.com</email>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- Python compiler with full language support and CPython compatibility
- This Python compiler achieves full language compatibility and compiles Python
- code into compiled objects that are not second class at all. Instead they can
- be used in the same way as pure Python objects.
- </longdescription>
- <upstream>
- <remote-id type="github">Nuitka/Nuitka</remote-id>
- <remote-id type="pypi">Nuitka</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/nuitka/nuitka-0.6.16.3.ebuild b/dev-python/nuitka/nuitka-0.6.16.3.ebuild
deleted file mode 100644
index 8810e82b4d14..000000000000
--- a/dev-python/nuitka/nuitka-0.6.16.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
- doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/nuitka/nuitka-0.6.16.4.ebuild b/dev-python/nuitka/nuitka-0.6.16.4.ebuild
deleted file mode 100644
index 758649696b8e..000000000000
--- a/dev-python/nuitka/nuitka-0.6.16.4.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
- doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}