summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numexpr')
-rw-r--r--dev-python/numexpr/Manifest1
-rw-r--r--dev-python/numexpr/files/numexpr-2.8.1-numpy-1.23.0.patch22
-rw-r--r--dev-python/numexpr/numexpr-2.8.1-r1.ebuild38
-rw-r--r--dev-python/numexpr/numexpr-2.8.1.ebuild33
4 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index 3c4e3b144f8d..634719c086b6 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,2 +1 @@
-DIST numexpr-2.8.1.tar.gz 111984 BLAKE2B b5d0b5bd5507c8c513db6404917b6256d9c8d232ea5d2f027f42cdac4a5e5c5f8c2db3d2283734f80d0ae7df2551314d088ccd2ed8e2c7401cc04a15ad61751d SHA512 243cddcb1fece9410e35c87a4c3f794ac0963ddfcc054b9a9c9842a2bb4e782d6c939f532d00d724d4b447d915764c3c8bbb87a99c71a22951798329aa7494bd
DIST numexpr-2.8.3.gh.tar.gz 112551 BLAKE2B c433e27dafe14e0760cd825992a4dcf3e35ae7a32c1bb768c6f5632e8505be5b10dc08a89c97836f019e53d77cf4aa811cc0822832d605934e35ae93e1cbb661 SHA512 4753159f8247ed18dba01d4db21e8e0a149a253cfc064719c9ccdcdd779d109aca64d2306820d912c274b5b6037a9dc849285ef015fec1e1dc9f0c8bad246393
diff --git a/dev-python/numexpr/files/numexpr-2.8.1-numpy-1.23.0.patch b/dev-python/numexpr/files/numexpr-2.8.1-numpy-1.23.0.patch
deleted file mode 100644
index b0e841077620..000000000000
--- a/dev-python/numexpr/files/numexpr-2.8.1-numpy-1.23.0.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/pydata/numexpr/commit/1c6a024947c3aa1bf926ecb9828036b306d7c6d7
-https://bugs.gentoo.org/853955
-
-From 1c6a024947c3aa1bf926ecb9828036b306d7c6d7 Mon Sep 17 00:00:00 2001
-From: Robert McLeod <robbmcleod@gmail.com>
-Date: Mon, 24 Jan 2022 10:54:34 -0800
-Subject: [PATCH] Fix for #397, use of NPY_ARRAY_UPDATEIFCOPY flag
-
- Changes from 2.8.0 to 2.8.1
- ---------------------------
---- a/numexpr/interpreter.cpp
-+++ b/numexpr/interpreter.cpp
-@@ -1269,7 +1269,7 @@ NumExpr_run(NumExprObject *self, PyObject *args, PyObject *kwds)
- }
- Py_INCREF(dtypes[0]);
- a = (PyArrayObject *)PyArray_FromArray(operands[0], dtypes[0],
-- NPY_ARRAY_ALIGNED|NPY_ARRAY_UPDATEIFCOPY);
-+ NPY_ARRAY_ALIGNED);
- if (a == NULL) {
- goto fail;
- }
-
diff --git a/dev-python/numexpr/numexpr-2.8.1-r1.ebuild b/dev-python/numexpr/numexpr-2.8.1-r1.ebuild
deleted file mode 100644
index 55c558ac78d4..000000000000
--- a/dev-python/numexpr/numexpr-2.8.1-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-numpy-1.23.0.patch
-)
-
-python_test() {
- pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
- "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
- import sys,numexpr
- sys.exit(0 if numexpr.test().wasSuccessful() else 1)
- EOF
- pushd >/dev/null || die
-}
diff --git a/dev-python/numexpr/numexpr-2.8.1.ebuild b/dev-python/numexpr/numexpr-2.8.1.ebuild
deleted file mode 100644
index 915229e23609..000000000000
--- a/dev-python/numexpr/numexpr-2.8.1.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
- import sys,numexpr
- sys.exit(0 if numexpr.test().wasSuccessful() else 1)
- EOF
- pushd >/dev/null || die
-}