summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oauthlib/oauthlib-3.1.1.ebuild')
-rw-r--r--dev-python/oauthlib/oauthlib-3.1.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/oauthlib/oauthlib-3.1.1.ebuild b/dev-python/oauthlib/oauthlib-3.1.1.ebuild
deleted file mode 100644
index 0f8ea8ae54b8..000000000000
--- a/dev-python/oauthlib/oauthlib-3.1.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
-HOMEPAGE="https://github.com/oauthlib/oauthlib https://pypi.org/project/oauthlib/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-# optional extras hard set as RDEPs. See setup.py
-RDEPEND="
- >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest