summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openapi-schema-validator/openapi-schema-validator-0.6.0.ebuild')
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.6.0.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.0.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.0.ebuild
deleted file mode 100644
index 5f31e9af50cc..000000000000
--- a/dev-python/openapi-schema-validator/openapi-schema-validator-0.6.0.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="OpenAPI schema validation for Python"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-schema-validator/
- https://pypi.org/project/openapi-schema-validator/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- <dev-python/jsonschema-5[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-specifications-2023.5.2[${PYTHON_USEDEP}]
- dev-python/rfc3339-validator[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e '/--cov/d' -i pyproject.toml || die
- distutils-r1_src_prepare
-}