summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openpyxl/openpyxl-3.0.7-r1.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-3.0.7-r1.ebuild b/dev-python/openpyxl/openpyxl-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..b5ef708e1bec
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+SRC_URI="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+
+RDEPEND="
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/openpyxl-3.0.7-metadata.patch
+)