summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild')
-rw-r--r--dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild b/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
new file mode 100644
index 000000000000..9a99ae747093
--- /dev/null
+++ b/dev-python/openstackdocstheme/openstackdocstheme-2.3.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Theme and extension support for Sphinx documentation"
+HOMEPAGE="https://docs.openstack.org/openstackdocstheme/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+BDEPEND=">dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"