summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/os-service-types/os-service-types-1.1.0.ebuild')
-rw-r--r--dev-python/os-service-types/os-service-types-1.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/os-service-types/os-service-types-1.1.0.ebuild b/dev-python/os-service-types/os-service-types-1.1.0.ebuild
new file mode 100644
index 000000000000..489c644e010c
--- /dev/null
+++ b/dev-python/os-service-types/os-service-types-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="A library to handle official service types for OpenStack and it's aliases."
+HOMEPAGE="https://github.com/openstack/os-service-types"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"