summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/os-service-types/os-service-types-1.7.0-r1.ebuild')
-rw-r--r--dev-python/os-service-types/os-service-types-1.7.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/os-service-types/os-service-types-1.7.0-r1.ebuild b/dev-python/os-service-types/os-service-types-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..c584d91bf3cb
--- /dev/null
+++ b/dev-python/os-service-types/os-service-types-1.7.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to handle official service types for OpenStack and it's aliases."
+HOMEPAGE="https://github.com/openstack/os-service-types"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+RDEPEND="${CDEPEND}"
+BDEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest