summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-concurrency/oslo-concurrency-5.1.1.ebuild')
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.1.1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.1.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.1.1.ebuild
deleted file mode 100644
index cb1cd4f30dee..000000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-5.1.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Oslo Concurrency library"
-HOMEPAGE="
- https://opendev.org/openstack/oslo.concurrency/
- https://github.com/openstack/oslo.concurrency/
- https://pypi.org/project/oslo.concurrency/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # fails, then hangs
- rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- eunittest
-}