summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest2
-rw-r--r--dev-python/oslo-i18n/metadata.xml3
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild35
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild35
4 files changed, 38 insertions, 37 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index fe6bee888c34..2d67e2ff6f68 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1 +1 @@
-DIST oslo.i18n-5.0.1.tar.gz 44636 BLAKE2B 69df723bff7a279ace2a8bb2ea795e6beaa626ffc4bb364c513d16d2ce3cb07f6e9957a98d1b633f95154672d118de6fbb71ef5c1a3a53520f4d1f4b8f72748f SHA512 d55238616dc90f85ff458fc6680b3a3b2493d2a640bf5849c19cd7271e7127b535a301ed3085b5e0131b46a635b5a09423f6cba60f9f1b9b0352a0e7115a8057
+DIST oslo.i18n-6.3.0.tar.gz 48207 BLAKE2B 20a882516dd45da8dda34127ba422a619decd982f01adeee5909b8646d49c8609ecb6adad4fc48ab32e820c4dcf4a42d4baf7e776983daf4586ae944b738bb6e SHA512 483ff39425b3fc5c6c54a3502a78a53406ccb3cdb7aff0836b9c2a49b8146fd931e2b4f3133d708d33d16bd99155f8cbcf8505491d74de5016da5e647a069a15
diff --git a/dev-python/oslo-i18n/metadata.xml b/dev-python/oslo-i18n/metadata.xml
index 0e46ed659e40..c287d67c03ac 100644
--- a/dev-python/oslo-i18n/metadata.xml
+++ b/dev-python/oslo-i18n/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
@@ -17,5 +17,6 @@
<upstream>
<remote-id type="pypi">oslo.i18n</remote-id>
<remote-id type="launchpad">oslo</remote-id>
+ <remote-id type="github">openstack/oslo.i18n</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild
deleted file mode 100644
index 29cb1ee5c79f..000000000000
--- a/dev-python/oslo-i18n/oslo-i18n-5.0.1-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Oslo i18n library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
diff --git a/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild
new file mode 100644
index 000000000000..2dc5bb3ea861
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-6.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.i18n/
+ https://github.com/openstack/oslo.i18n/
+ https://pypi.org/project/oslo.i18n/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest