summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild')
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild
deleted file mode 100644
index 4c4b475ddc24..000000000000
--- a/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.config/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
-S="${WORKDIR}/oslo.rootwrap-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}