summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/Manifest2
-rw-r--r--dev-python/owslib/owslib-0.28.1.ebuild53
-rw-r--r--dev-python/owslib/owslib-0.29.0.ebuild56
3 files changed, 0 insertions, 111 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 5fd49d0a5396..86962121dade 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1,3 +1 @@
-DIST OWSLib-0.28.1.gh.tar.gz 950453 BLAKE2B 8210efdea8ac2536348659a1bed46b5eb1b4da5a8b77979cc11d23273b1f806bef21d007ddd8a6961c16e241c4f3e18c93054c8abaa89baf8b765c98d74605d0 SHA512 bd62a5e371e64e0e256cc83d2f044294c20965f6b107b0dd9074ac752971620f01af4c7fc9a82e43dc81e71a6a36696b75403012841c28925b017d9c47b2d4a5
-DIST OWSLib-0.29.0.gh.tar.gz 960632 BLAKE2B 11fdf8a2c89f187afe9010ec35722ad48a3a06957233f50a82e53d9f359278e3a722e55352c5c5110fa93c59d03a7183354f891c1d8fc4527cf299edd4fcd474 SHA512 f0f657bb7ca36d7abcf8ce606806b18ea05b7161e7571cf7ac7142a2d0fc632bb3d530a38f70822e0791317b081fcc8a6680c2d4aa64130ca8fe353774b05a72
DIST OWSLib-0.29.1.gh.tar.gz 960582 BLAKE2B e88446a843113453b116016a4488e1738472b2ff8faf7f0b1647db061e2af4b15e7ca64fb92d3298a9c4e906f8230a03fea664df65113dedba901a75c074da2e SHA512 10fc2d75b60c6a388d4729011e3843d0943e6273c94d628b288c973304c01359d77a4856a7dc74ac28358f26cbe9ffe85a67921ef5eb62475d2143dd20c46e08
diff --git a/dev-python/owslib/owslib-0.28.1.ebuild b/dev-python/owslib/owslib-0.28.1.ebuild
deleted file mode 100644
index 8cdb2011c3ce..000000000000
--- a/dev-python/owslib/owslib-0.28.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=OWSLib-${PV}
-DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
-HOMEPAGE="
- https://geopython.github.io/OWSLib/
- https://github.com/geopython/owslib/
- https://pypi.org/project/OWSLib/
-"
-SRC_URI="
- https://github.com/geopython/${PN}/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-RESTRICT="test"
-PROPERTIES="test_network"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # connection errors
- tests/test_wfs_generic.py::test_xmlfilter_wfs_110
- tests/test_wfs_generic.py::test_xmlfilter_wfs_200
-)
-
-python_test() {
- epytest -o addopts=
-}
diff --git a/dev-python/owslib/owslib-0.29.0.ebuild b/dev-python/owslib/owslib-0.29.0.ebuild
deleted file mode 100644
index 957ae9d2ba3c..000000000000
--- a/dev-python/owslib/owslib-0.29.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=OWSLib-${PV}
-DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
-HOMEPAGE="
- https://geopython.github.io/OWSLib/
- https://github.com/geopython/owslib/
- https://pypi.org/project/OWSLib/
-"
-SRC_URI="
- https://github.com/geopython/${PN}/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="test"
-PROPERTIES="test_network"
-
-RDEPEND="
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # connection errors
- tests/test_wfs_generic.py::test_xmlfilter_wfs_110
- tests/test_wfs_generic.py::test_xmlfilter_wfs_200
- tests/test_ogcapi_records_pycsw.py::test_ogcapi_records_pycsw
- tests/test_opensearch_pycsw.py::test_opensearch_creodias
- tests/test_ows_interfaces.py::test_ows_interfaces_csw
-)
-
-python_test() {
- epytest -o addopts=
-}