summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paginate/paginate-0.5.6.ebuild')
-rw-r--r--dev-python/paginate/paginate-0.5.6.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/paginate/paginate-0.5.6.ebuild b/dev-python/paginate/paginate-0.5.6.ebuild
index 65692bbfe32b..81835e8a3b27 100644
--- a/dev-python/paginate/paginate-0.5.6.ebuild
+++ b/dev-python/paginate/paginate-0.5.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1
@@ -28,6 +28,8 @@ python_test() {
local EPYTEST_DESELECT=()
case ${EPYTHON} in
+ python3.13)
+ ;&
python3.12)
EPYTEST_DESELECT+=(
# these tests assume that dict is not sliceable