summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/parver/parver-0.2.1.ebuild')
-rw-r--r--dev-python/parver/parver-0.2.1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/parver/parver-0.2.1.ebuild b/dev-python/parver/parver-0.2.1.ebuild
deleted file mode 100644
index c18e7ee504f7..000000000000
--- a/dev-python/parver/parver-0.2.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Parse and manipulate version numbers"
-HOMEPAGE="https://github.com/RazerM/parver https://pypi.org/project/parver/"
-SRC_URI="https://github.com/RazerM/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.2.1-gentoo-versioning.patch
-)
-
-RDEPEND="
- >=dev-python/arpeggio-1.7[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- "
-
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pretend[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- pytest -vv || die "Testing failed"
-}