summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/passlib')
-rw-r--r--dev-python/passlib/passlib-1.7.4-r3.ebuild (renamed from dev-python/passlib/passlib-1.7.4-r2.ebuild)24
1 files changed, 21 insertions, 3 deletions
diff --git a/dev-python/passlib/passlib-1.7.4-r2.ebuild b/dev-python/passlib/passlib-1.7.4-r3.ebuild
index 708ef7f23b53..19f9172fdcb4 100644
--- a/dev-python/passlib/passlib-1.7.4-r2.ebuild
+++ b/dev-python/passlib/passlib-1.7.4-r3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 optfeature pypi
@@ -15,8 +15,8 @@ HOMEPAGE="
"
LICENSE="BSD-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
IUSE="doc test-rust"
BDEPEND="
@@ -30,12 +30,30 @@ BDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # fix compatibility with >=dev-python/bcrypt-4.1
+ # https://foss.heptapod.net/python-libs/passlib/-/issues/190
+ sed -i -e '/bcrypt/s:__about__\.::' passlib/handlers/bcrypt.py || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
local EPYTEST_DESELECT=(
# broken all the time by new django releases
passlib/tests/test_ext_django.py
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # crypt module has been removed, so the platform backend
+ # does not work anymore
+ passlib/tests/test_handlers.py::{des,md5,sha256,sha512}_crypt_os_crypt_test
+ )
+ ;;
+ esac
+
# skip fuzzing tests, they are very slow
epytest -k "not fuzz_input"
}