summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/Manifest1
-rw-r--r--dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild43
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pastedeploy/Manifest b/dev-python/pastedeploy/Manifest
index 3c49b81829c8..13af0bc6a3ef 100644
--- a/dev-python/pastedeploy/Manifest
+++ b/dev-python/pastedeploy/Manifest
@@ -1,2 +1 @@
-DIST pastedeploy-2.1.1.tar.gz 32339 BLAKE2B d11affa480e5c9b7be53d0431090e4ec9d66f8862b1aadf6a993a09f9c952380d7698eaa7442614936a8316e2ac50404a096bf64bb3ef31f55cbee35b5982166 SHA512 0109e30cb5ae9bdd7f06a79f6236c90f96c3bcfe507258572b1329796a1821486d9762d954673ccbac76ee63c6a69e64fe5e2cae5402fecf4a5affe88cf46930
DIST pastedeploy-3.0.1.gh.tar.gz 33420 BLAKE2B d96e9429852ce2f6b82aac834c3a1da069f02d542f7379935e42a9e663cdee807230bbede3acc03fb5cccc3b4462d3f3afaa84eec09225bbaffe6ece4534f3fe SHA512 2b06351b9104da1e0d30c90492ee31113aacf5cde7a66a34482c4625af902b855eab2af80073db4eb18805a192f858dac360062dadf58a161cc3cfabf5b67a1a
diff --git a/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild b/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
deleted file mode 100644
index 8fda2c1f81ff..000000000000
--- a/dev-python/pastedeploy/pastedeploy-2.1.1-r3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="PasteDeploy"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Load, configure, and compose WSGI applications and servers"
-HOMEPAGE="
- https://github.com/Pylons/pastedeploy/
- https://pypi.org/project/PasteDeploy/
-"
-# pypi tarball does not include tests
-SRC_URI="
- https://github.com/Pylons/pastedeploy/archive/${PV}.tar.gz
- -> ${P}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
-
-RDEPEND="
- !dev-python/namespace-paste
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-change-sphinx-theme.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx_rtd_theme
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}