summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/phonenumbers')
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-8.13.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index 67864b286d1d..38e2af5d6c2d 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1,2 +1,3 @@
+DIST python-phonenumbers-8.13.10.gh.tar.gz 4910354 BLAKE2B c78fc4159fe6758e9fd1afb9acfb6d0d29878b599b0c151e5ad02221fcedd7cbafb3ceb479dc95549776da9fa896a09871677efbaafb5d5fde2bfb19db9c4780 SHA512 08b09903e3a84324b6128b007c1a805d8c9e5216afd4c72b25d71d2b62719032c373e53b663303b9ae2b90465214e36141050467a860d187e826ee76b1a80445
DIST python-phonenumbers-8.13.8.gh.tar.gz 4910864 BLAKE2B 33babe7aa0f487398311817fa901a56ac8a7470f2e4338700529f35c7622cf9b663bd404f6c1087600c03fd2844a1c777ed81d2e61d9cc2f0ff78e68a0276624 SHA512 6e2ee96aa9c20188b276cdeac1365fddb339feb63e8d5e9f61ae82f6aa19cc6564a5f1dbf687d6cc69c2cfa21fbb14892f880677ac7ba734a949183711faca5a
DIST python-phonenumbers-8.13.9.gh.tar.gz 4910883 BLAKE2B 596010af1526a4058f3db8ac1bb087d59dd93d1223ad54c50444740c3b6eb0d0ee4da83ec2882140f3325740575bd808ecd9726b9d583420283c25285cdd32c3 SHA512 24ae70a9d6b5830261d719c5a003ab6909ef9b759c53bfe7e78d7ad7062ad878bc2109b92041266ecd798b92d94392b53d02c6f51446e88d8c20dc4b48a10b4f
diff --git a/dev-python/phonenumbers/phonenumbers-8.13.10.ebuild b/dev-python/phonenumbers/phonenumbers-8.13.10.ebuild
new file mode 100644
index 000000000000..20fb3f38daee
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-8.13.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="
+ https://github.com/daviddrysdale/python-phonenumbers/
+ https://pypi.org/project/phonenumbers/
+"
+SRC_URI="
+ https://github.com/daviddrysdale/python-phonenumbers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ../README.md )
+
+python_test() {
+ "${EPYTHON}" testwrapper.py -v || die "Tests failed with ${EPYTHON}"
+}