summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/picobox/picobox-4.0.0.ebuild')
-rw-r--r--dev-python/picobox/picobox-4.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/picobox/picobox-4.0.0.ebuild b/dev-python/picobox/picobox-4.0.0.ebuild
new file mode 100644
index 000000000000..d90325db0781
--- /dev/null
+++ b/dev-python/picobox/picobox-4.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Dependency injection framework designed with Python in mind"
+HOMEPAGE="
+ https://github.com/ikalnytskyi/picobox/
+ https://pypi.org/project/picobox/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest