summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/picobox')
-rw-r--r--dev-python/picobox/Manifest1
-rw-r--r--dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch26
-rw-r--r--dev-python/picobox/metadata.xml13
-rw-r--r--dev-python/picobox/picobox-2.2.0.ebuild30
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/picobox/Manifest b/dev-python/picobox/Manifest
new file mode 100644
index 000000000000..b99d37fb1e9c
--- /dev/null
+++ b/dev-python/picobox/Manifest
@@ -0,0 +1 @@
+DIST picobox-2.2.0.tar.gz 30231 BLAKE2B 9911e2e41a850b57d4a642aa454e55703e0546bdb3a5b95aa4a15747388413babaec7dc3a3f7fcb7ecae7ecd0f81dc203161975ca393f87353987825e0413355 SHA512 d127ea71637105285701ae5252e59e0c940077fbbe044ba1f42f80134ea08291344ebb6bc8bce240112a7efe0be8561c8040b43d20912f1fbd121098578a1795
diff --git a/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch b/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
new file mode 100644
index 000000000000..74c6f9b2193f
--- /dev/null
+++ b/dev-python/picobox/files/picobox-2.2.0-fix-py3.10.patch
@@ -0,0 +1,26 @@
+diff --git a/tests/test_box.py b/tests/test_box.py
+index c1c1ca2..d576086 100644
+--- a/tests/test_box.py
++++ b/tests/test_box.py
+@@ -402,7 +402,7 @@ def test_box_pass_unexpected_argument(boxclass):
+ with pytest.raises(TypeError) as excinfo:
+ fn(1, 2)
+
+- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
++ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
+
+
+ def test_box_pass_keyerror(boxclass):
+diff --git a/tests/test_stack.py b/tests/test_stack.py
+index 725d378..10129b3 100644
+--- a/tests/test_stack.py
++++ b/tests/test_stack.py
+@@ -472,7 +472,7 @@ def test_box_pass_unexpected_argument(boxclass, teststack):
+ with pytest.raises(TypeError) as excinfo:
+ fn(1, 2)
+
+- assert str(excinfo.value) == "fn() got an unexpected keyword argument 'd'"
++ assert "fn() got an unexpected keyword argument 'd'" in str(excinfo.value)
+
+
+ def test_box_pass_keyerror(boxclass, teststack):
diff --git a/dev-python/picobox/metadata.xml b/dev-python/picobox/metadata.xml
new file mode 100644
index 000000000000..4c33fc7d9bd9
--- /dev/null
+++ b/dev-python/picobox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">picobox</remote-id>
+ <remote-id type="github">ikalnytskyi/picobox</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/picobox/picobox-2.2.0.ebuild b/dev-python/picobox/picobox-2.2.0.ebuild
new file mode 100644
index 000000000000..5a25c40a8670
--- /dev/null
+++ b/dev-python/picobox/picobox-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Dependency injection framework designed with Python in mind"
+HOMEPAGE="https://pypi.org/project/picobox/
+ https://github.com/ikalnytskyi/picobox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest