summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pikepdf/pikepdf-1.8.3.ebuild')
-rw-r--r--dev-python/pikepdf/pikepdf-1.8.3.ebuild37
1 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/pikepdf/pikepdf-1.8.3.ebuild b/dev-python/pikepdf/pikepdf-1.8.3.ebuild
index 27d20472d7ef..03166127d0d0 100644
--- a/dev-python/pikepdf/pikepdf-1.8.3.ebuild
+++ b/dev-python/pikepdf/pikepdf-1.8.3.ebuild
@@ -11,8 +11,41 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
RDEPEND="app-text/qpdf
+ dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]"
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? ( >=dev-python/attrs-19.1.0
+ >=dev-python/hypothesis-4.24
+ <dev-python/hypothesis-5.0
+ >=dev-python/pillow-5.0.0
+ >=dev-python/pytest-4.4.0
+ <dev-python/pytest-5.0.0
+ >=dev-python/pytest-xdist-1.28
+ <dev-python/pytest-xdist-2.0
+ >=dev-python/pytest-helpers-namespace-2019.1.8
+ >=dev-python/pytest-timeout-1.3.3
+ >=dev-python/python-xmp-toolkit-2.0.1 )"
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+python_test() {
+ pytest
+}
+
+# When ipythom and matplotlib will get python3_8 support, we'll be able to add
+#
+#IUSE="doc"
+#DEPEND="doc? ( dev-python/ipython
+# dev-python/matplotlib
+# dev-python/sphinx-1.4
+# dev-python/sphinx_rtd_theme )"
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+#python_install_all() {
+# use doc && local HTML_DOCS=( docs/_build/html/. )
+# distutils-r1_python_install_all
+#}