summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pip/pip-21.0.ebuild')
-rw-r--r--dev-python/pip/pip-21.0.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/pip/pip-21.0.ebuild b/dev-python/pip/pip-21.0.ebuild
index 43ecef72bc5d..97ec97de5ecf 100644
--- a/dev-python/pip/pip-21.0.ebuild
+++ b/dev-python/pip/pip-21.0.ebuild
@@ -9,8 +9,10 @@ PYTHON_REQ_USE="ssl(+),threads(+)"
inherit bash-completion-r1 distutils-r1
-SETUPTOOLS_PV="44.0.0"
-WHEEL_PV="0.34.2"
+# setuptools & wheel .whl files are required for testing,
+# the exact version is not very important.
+SETUPTOOLS_WHL="setuptools-51.3.3-py3-none-any.whl"
+WHEEL_WHL="wheel-0.36.2-py2.py3-none-any.whl"
DESCRIPTION="Installs python packages -- replacement for easy_install"
HOMEPAGE="
@@ -20,12 +22,11 @@ HOMEPAGE="
SRC_URI="
https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
test? (
- https://files.pythonhosted.org/packages/py2.py3/s/setuptools/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl
- https://files.pythonhosted.org/packages/py2.py3/w/wheel/wheel-${WHEEL_PV}-py2.py3-none-any.whl
+ https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
+ https://files.pythonhosted.org/packages/py2.py3/w/wheel/${WHEEL_WHL}
)
"
# PyPI archive does not have tests, so we need to download from GitHub.
-# setuptools & wheel .whl files are required for testing, exact version is not very important.
LICENSE="MIT"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
@@ -69,10 +70,7 @@ python_prepare_all() {
if use test; then
mkdir tests/data/common_wheels/ || die
- cp "${DISTDIR}"/setuptools-${SETUPTOOLS_PV}-py2.py3-none-any.whl \
- tests/data/common_wheels/ || die
-
- cp "${DISTDIR}"/wheel-${WHEEL_PV}-py2.py3-none-any.whl \
+ cp "${DISTDIR}"/{${SETUPTOOLS_WHL},${WHEEL_WHL}} \
tests/data/common_wheels/ || die
fi
}