summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pipdeptree')
-rw-r--r--dev-python/pipdeptree/Manifest1
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.14.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index 21b7d62ce204..df8a3b3af636 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -1,2 +1,3 @@
DIST pipdeptree-2.13.1.tar.gz 33139 BLAKE2B e7044303f09ad3952e14f79ec11e01a54e9c34ff5b4430094a968602c8a97388eadd4e021c97c97c1767d7ae02b7070ff6e4ec934aef6036b98bf2553d2344a0 SHA512 18c73a8ef458b0a241d967da40453fb8a9fc6550cbd2c21eecca9a81f011b896622fb45a81b79e30eb990454b6f518a1fcc02cb25bb2c5ca988b44e040264e26
DIST pipdeptree-2.13.2.tar.gz 33290 BLAKE2B 1b97dbfaa6f6baff272e6e6d5399f95b96e13b19bba5ef3997574d027002abd98152e26d67b4b19555392d076c84bf6b142d147d95349ba1dd535bea40994b4f SHA512 ce6cfc29827c087725366a95079621516303cf50c6c4ee4a0cd5d8b7649e8dd7b7145b62523c48731a2b5f4140c90c558eb5d1a0248b28a8c4c97ccb78d9e16d
+DIST pipdeptree-2.14.0.tar.gz 34392 BLAKE2B b10dde231fae896b114b9e9b71eb6925493d3814381a6497f0a9011ca7cea415b68db8913f6cae7d0b6da0f3c3801e96671238097b25f0bef6bfcb5c65e2ec80 SHA512 ff6be5782abe4d4ee0eeaee7c668736ad4a07237a9ecd1f0c1e42484668737f0e8a4a586e08b606849ccf358914dbaebe4907f67eba70b348c7a89791570eb11
diff --git a/dev-python/pipdeptree/pipdeptree-2.14.0.ebuild b/dev-python/pipdeptree/pipdeptree-2.14.0.ebuild
new file mode 100644
index 000000000000..88a5c229f6a9
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
+ "${FILESDIR}/pipdeptree-2.13.2-fix-pypy-7.3.14.patch"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}