summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pkginfo/pkginfo-1.5.0.1.ebuild')
-rw-r--r--dev-python/pkginfo/pkginfo-1.5.0.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild b/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild
new file mode 100644
index 000000000000..6716367c8a99
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.5.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs
+
+python_test() {
+ distutils_install_for_testing
+
+ pushd "${TEST_DIR}/lib" >/dev/null || die
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+ popd >/dev/null || die
+}