summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pkginfo/pkginfo-1.8.1.ebuild')
-rw-r--r--dev-python/pkginfo/pkginfo-1.8.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pkginfo/pkginfo-1.8.1.ebuild b/dev-python/pkginfo/pkginfo-1.8.1.ebuild
new file mode 100644
index 000000000000..090f27714158
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.org/project/pkginfo/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ # https://bugs.launchpad.net/pkginfo/+bug/1952946
+ pkginfo/tests/test_installed.py::InstalledTests::test_ctor_w_package_no_PKG_INFO
+ )
+
+ epytest
+}